MSTerminalServices.org Forums

Forums Home | FAQ | Search | Profile | Private Messages | Log in/Register/Password

Remote Desktop for Administration v.s. Terminal Services

Page 1 of 1
Next:  General Discussions: Printing Steps  
Author Message
Ryan

External


Since: Aug 06, 2004
Posts: 1



(Msg. 1) Posted: Fri Aug 06, 2004 4:46 pm
Post subject: Remote Desktop for Administration v.s. Terminal Services
Archived from groups: microsoft>public>windows>terminal_services (more info?)

So after discovering the hard way that turning on Terminal Services in
2003 isn't how you do remote administration (licensing grace period
ran out & I got the ever-wonderful "no licensing servers available"
error constantly), I attempted to proceed to do it the right way by
uninstalling Terminal Services and enabling Remote Desktop for
Administration.

Funny thing - I still received "no license servers" problems when
attempting to connect to the server. Odd. I tried (with Remote
Desktop disabled and rebooted before going farther) reinstalling TS,
rebooting, uninstalling TS, rebooting, enabling Remote Dektop for
Administration, rebooting (for good measure) with no luck - still got
"no licensing servers" errors when trying to connect.

I finally figured out there's gotta be a registry key that's not being
flipped when I do the TS uninstall. While digging around I found an
article on the web (here:
http://www.winnetmag.com/Article/ArticleID/42176/42176.html) relating
to an old bug in 2003 TS about a registry key that got reset which
controls the licensing mode (device vs user). I decided to poke at
that registry key set and there's a value titled:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server
TSEnabled, REG_DWORD, Hexidecimal, Data: 1

This struck me as odd since TS is registered in Add/Remove as being
UNINSTALLED. Thinking this may have something to do with the Terminal
Services service in 2003 (which everything remote deskop related
relies on) I keep poking, but kept coming back to this key. Finally I
bit the bullet and changed the above value from 1 to 0 and rebooted
the server with Remote Desktop for Administration enabled. Upon
completing reboot I start up Remote Desktop on my XP desktop and
attempt a non-/console session. *crossing fingers* IT WORKED! I
could establish a remote dektop connection without complaints of
licensing servers not being found. Finally!

Reminder: Through all this TS is registered in Add/Remove as being
UNINSTALLED and Remote Desktop is ENABLED, but the server still
returned "no license servers available" when trying to connect with
Remote Desktop.

Take note that through all this I could still connect to the /console
session via Start --> Run --> mstsc.exe /console, but that's not the
correct way to be connecting via Remote Desktop.
Back to top
Send e-mail Login to vote
Display posts from previous:   
    All times are: Eastern Time (US & Canada) (change) Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Looking for more Terminal Services info?

Sign up to the MSTerminalServices.org Monthly Newsletter, written by Terminal Server MVP & Citrix CTP Stefan Vermeulen, containing news, tips, interviews, links of the month and much more. Subscribe today and don't miss a thing!

Become an MSTerminalServices.org member!

Discuss your Terminal Services & Citrix issues with thousands of other SBC experts. Click here to join!

Community Area

Log in | Register